improved

Node.js v14 now the minimum supported version for mabl CLI

Since Node .js v12 LTS support went end of life on April 30, 2022, the mabl CLI now requires a minimum Node.js runtime version of v14 LTS or higher. Starting with CLI release v1.24.0 users should upgrade to Node.js v14 LTS or v16 LTS.

Users on older runtimes will see warning messages similar to the following, prompting them to upgrade. Upgrading will resolve the warning message.

To minimize upgrades to your Node.js runtimes, mabl encourages the use of Long Term Support (LTS) Node.js versions. The current Node.js LTS release is v16.

Additional information about Node.js releases can be found here.