improved

Node.js v16 now the minimum supported version for mabl CLI

Since Node .js v14 LTS support goes end of life on April 30, 2023, the mabl CLI now requires a minimum Node.js runtime version of v16 LTS or higher. Starting with CLI release v1.53.0 users should upgrade to Node.js v16 LTS or v18 LTS.

Users on older runtimes will see warning messages similar to the following, prompting them to upgrade. Upgrading will resolve the warning message.

To minimize upgrades to your Node.js runtimes, mabl encourages the use of Long Term Support (LTS) Node.js versions. The current Node.js LTS release is v18.

Additional information about Node.js releases can be found here.